R12.1.1 - Post installation Issues

Hi Everyone,

I have installed recently R12.1.1
After the installation faced issues bringing up the HTTP server.


Processes in Instance: r12test_myhost.myhost.mydomain.com
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status
-------------------+--------------------+---------+---------
OC4J | oafm | 11510 | Alive
OC4J | forms | 11508 | Alive
OC4J | oacore | 11509 | Alive
HTTP_Server | HTTP_Server | 0 | NONE
ASG | ASG | N/A | Down


06/10/09-00:11:48 :: adopmnctl.sh: exiting with status 0


adapcctl.txt showed the error message

06/10/09-00:04:03 :: adapcctl.sh: starting OPMN managed OHS instance

opmnctl: starting opmn managed processes...
================================================================================
opmn id=myhost.mydomain.com:6205
no processes or applications matched this request

06/10/09-00:04:06 :: adapcctl.sh: exiting with status 150

================================================================================


$LOG_HOME/ora/10.1.3/opmn/HTTP_Server~1 was giving the error


--------
09/06/10 00:25:49 Start process
--------
/app/inst/apps/r12test_myhost/ora/10.1.3/Apache/Apache/bin/apachectl startssl: execing httpd
/app/apps/tech_st/10.1.3/Apache/Apache/bin/httpd: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory


After doing bit research found that OEL 5 requires below symlink to be created to resolve this issue(note 564174.1)

# ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2


Processes in Instance: r12test_myhost.myhost.mydomain.com
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status
-------------------+--------------------+---------+---------
OC4J | oafm | 11510 | Alive
OC4J | forms | 11508 | Alive
OC4J | oacore | 11509 | Alive
HTTP_Server | HTTP_Server | 13858 | Alive
ASG | ASG | N/A | Down


adopmnctl.sh: exiting with status 0

Hooray, My instance came up!!
Will post some interesting posts on R12 with the newly created instance.

7 comments:

vanjangi kumar said...

Hi Suresh,


Its very much helpful to me. And i am new to this APPS world.i have one issue like in switch responsibility navigation tab i am finding some responsibilities having multiple entries.i am searching for that but i am unable get it.Please can you help me out? FYI R12.1.1 we are using.

Regards,
--Kishore
navigation: open any form and switch responsibility and there in that tab i am getting multiple entries of same responsibility

Suresh Lakshmanan said...

Hi Kishore,

Please send me the error messages if you see one. I am not quite clear with your doubt.
send screen shots if possible to explain. I try my best to help you out. You can raise the questions in oracle forums too(forums.oracle.com).

Thanks
Suresh

Supply chain planning said...

Hi Suresh,
The information was really good , I have one quick question here , we have deployed demantra in our server after deployment colloborator pages are opening , i have started the workflow EBS full download and got the message MsgDownloadOK , whereas when i started EBS upload local forecast iam getting an error Fail_to_execute_step , could you please throw some light on this error , if you have faced this before
Thanks and Regards
P.Venkatesh Prabu
Sr ASCP and Planning consultant
Chennai
India

Adnan Rafi said...

according to Oracle Metalink Support (Note #402310.1)
apply patch 6078836 for that error

Suresh Lakshmanan said...

Thanks Adnan. :-) Patch would have come recently than the post.

Suresh

Amit Shukla said...

Hi Suresh,
I'm facing the same issue that you mentioned (

09/20/12-01:19:35 :: adoacorectl.sh: Starting OPMN managed OACORE OC4J instance

opmnctl: starting opmn managed processes...
================================================================================
opmn id=ip-10-189-119-235.ec2.internal:6201
no processes or applications matched this request

09/20/12-01:19:35 :: adoacorectl.sh: exiting with status 150
)

I tried to create the soft link as you u suggested
(
ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.
)

but it seems it is already there on my machine


[oracle@ip-10-218-53-224 lib]$ ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2
ln: creating symbolic link `/usr/lib/libdb.so.2' to `/usr/lib/libgdbm.so.2.0.0': File exists


Any other hint that might resolve the issue?

Thanx
Amit

Suresh Lakshmanan said...

Please check metalink for any other hits. I do not have any other test instance now to do some play.

Suresh